
© 2024 inoage GmbH

MADRIX STELLA User Manual

Date: May 2024

[Hardware User Guide]



//2

Table Of Contents

www.madrix.com

Table Of Contents

Part 1 Overview 3

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  41 Introduction

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  52 Hardware Features

Part 2 Device Configuration 12

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  131 Web Configuration [Ethernet]

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  232 MADRIX HARDWARE MANAGER [USB / Ethernet]

Part 3 Using MADRIX 5 Software 27

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  291 Output [Art-Net]

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  422 Output [sACN]

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  503 Output [USB]

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  554 Input [Art-Net]

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  685 Input [sACN]

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  806 Input [USB]

Part 4 Technical Support 91

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  921 Firmware Updates

Part 5 General 99

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1001 Glossary

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1052 PC Power Management

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1093 Tips [Microsoft Windows / Networks / USB]

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1244 Web Links

Part 6 Legal 125

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1261 Imprint And Copyright



1//PART 
Overview



[Part 1] Overview

//4www.madrix.com

MADRIX STELLA User Manual

1 Overview

Topics Of This Chapter

§ Introduction

§ Hardware Features

1.1 Introduction

This topic includes:

§ MADRIX STELLA

MADRIX STELLA

MADRIX STELLA is a 2-port network node with RDM support for solid-state projects.

The MADRIX STELLA is a dedicated control interface for DMX512 and Art-Net or Streaming ACN that

is designed for high quality and practicability in permanent LED installations.
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1.2 Hardware Features

This topic includes:

§ Using A 3rd-Party Controller

§ Putting The Device Into Operation

§ LED Status Codes

§ Automatic HTP Merging

§ Remote Device Management [RDM]

§ Daisy-Chain Support

§ Reset To Factory Default Settings

§ Initiate Poll

Using A 3rd-Party Controller

MADRIX STELLA is a standard network node. Because of this, you can use the device with

applications, consoles, desks, or controllers that are compatible with Art-Net or Streaming ACN

[sACN] to distribute network data via Ethernet network.

Putting The Device Into Operation

1] Connecting Your LED Fixtures

See the MADRIX STELLA Technical Manual & Quick Start Guide on how to connect your LED

fixtures to MADRIX STELLA. 

»help.madrix.com

http://help.madrix.com/
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2] Connecting To Power And Data

See the MADRIX STELLA Technical Manual & Quick Start Guide on how to connect to power and

data. 

»help.madrix.com

3] Device Settings

Make sure to set the correct network data source and other settings according to the

controller/sender you want to use.

Learn more:

§ »Configuration Using A Web Browser 

LED Status Codes

The following tables describe the LED status codes of the device.

STATUS STATUS LED POWER

Powered off Power not connected. > The device has no power.

Permanently green Connected to power. > The power is on.

Blinking green Bootloader activated. > Reset device / upload firmware.

STATUS STATUS LED USB

Powered off USB not connected.

Red +
blinking green

Communicating over USB.
> Sending or receiving data over USB. The USB port works.

Fading between
red +green

Connected to USB; Drivers installed correctly.
> No data is sent over USB.

http://help.madrix.com/
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Orange Connected to USB; No drivers installed.
> Reinstall software and drivers or try a different USB port.

STATUS STATUS LED DMX 1 STATUS LED DMX 2

Powered off No data is sent. No data is sent.

Blinking green Sending or receiving data.
> The DMX port works.

Sending or receiving data.
> The DMX port works.

STATUS STATUS LEDS ETHERNET PORTS

Green off 10 MBit/s connected.

Green on 100 MBit/s connected.

Orange on Network connected.

Orange blinking Sending or receiving data. > The Ethernet port works.

Automatic HTP Merging

Overview

§ MADRIX STELLA features automatic HTP merging from 2 Ethernet sources.

[Usually, the first source will be MADRIX 5. The second source could be a console, for example.]

§ Data from both source will be merged together and sent out as 1 signal. This happens across all

8 output ports and by using the HTP principle.

§ HTP - Is the acronym for Highest Takes Precedence. Data from both sources will be compared

for each individual channel. The higher value wins per channel.

§ Sources can be:

- 1x Art-Net + 1x Art-Net

- 1x Art-Net + 1x sACN

- 1x sACN + 1x sACN
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§ Example: We are using an LED fixture with a total of 5 control channels [3 color channels and 2

movement channels]. MADRIX 5 should provide the color data for channels 1 to 3 and the

console should provide the movement data for channels 4 and 5. Using the MADRIX 5 Fixture

Editor, we could create a corresponding fixture where channel 4 and 5 are set up as Fixed

channel using always a value of 0. On the other hand, the console will always send a value of 0

for the first 3 channels of each fixture. This will ensure that the data from the console will

always provide the higher value on channels 4 and 5, while MADRIX 5 provides the color data.

Due to the automatic HTP merging of the device, the LED fixture will receive correct data from

both sources as desired.

Configuration And Recommendations When Merging Art-Net

1] Correctly set up and enable Art-Net for each source.

2] Make sure to activate ArtSync for Art-Net in MADRIX 5 . Learn more »Sync Mode 

3] Make sure that MADRIX 5 has a different IP address in the same IP address range compared to

the second source.

4] Always use Unicast Mode in MADRIX 5 to directly send data to the correct IP addresses of

your MADRIX STELLA devices. 

[It is not recommend to have any of the two sources or any other source in the network to send

data via Broadcast Mode.]

Remote Device Management [RDM]

In order to use it, call up the built-in web configuration [see below] and go to DMX Output Settings

> Enable RDM for ports DMX 1 and/or DMX 2

Make sure to disable RDM on the specific port, when using STELLA for input [DMX-IN].

RDM is fully supported over Art-Net, including ArtRdm, all other required packets, and full and

continued discovery of RDM devices.

Thanks to STELLA's Packet Multitasking, RDM and Art-Net can be sent and received at the same time
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and during live operation with a min. frame rate of 22 FPS, an expected average of 34 FPS, and a

max. frame rate of 44 FPS, depending on the number of RDM packets.

Daisy-Chain Support

STELLA features 2 separate Ethernet network ports. Either one is fully functionally for IN and OUT

and can be used for the data connection without using a separate network switch or router. 

We recommend to connect a maximum of 40 units after one another in a row, when using Art-Net in

Unicast Mode or Streaming ACN Multicast at a max. data rate of 50 FPS / 20 ms without any

additional devices in the network.

In the MADRIX 5 Software, we highly recommend to activate ArtSync for excellent image quality [see

below].

Reset To Factory Default Settings

In rare cases, you might need to do a reset to factory default settings, for example to reset to the

device to its default IP address as shown on the side of the device:

Reset Via Reset Button

§ 1] Disconnect all connections from the device [power, data, DMX].

§ 2] Use a suitable tool to press the reset button [between DMX 1 and 2].

§ 3] Continue to press the reset button and supply power again over 'Power' or USB.

§ 4] Continue to press the reset button and wait until all status LEDs of the device flash

repeatedly or wait 10 seconds.

[Simply repeat these steps should the process fail.]
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Reset Via Ethernet [Web Configuration]

§ 1] Connect MADRIX STELLA to power.

[Please see safety instructions in the MADRIX STELLA Technical Manual & Quick Start Guide]

§ 2] Connect MADRIX STELLA and your computer to the same Ethernet network.

§ 3] Assign correct network settings for your computer in the operating system. 

[Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]

§ 4] Open your web browser and enter the IP address of MADRIX STELLA. The built-in web

configuration tool will be launched.

[You can find the default IP address on the side of the device.]

§ 5] Click Reset

Learn more »Web Configuration [Ethernet]

Reset Via USB Or Ethernet [MADRIX HARDWARE MANAGER]

§ 1] Connect MADRIX STELLA to power.

[Please see safety instructions in the MADRIX STELLA Technical Manual & Quick Start Guide]

§ 2] Connect MADRIX STELLA to your computer via USB or Ethernet.

[You can use the provided USB cable or a separate network cable is required.]

§ 3] Start the separate MADRIX HARDWARE MANAGER

[In Windows 10, go to Start > MADRIX HARDWARE MANAGER > MADRIX HARDWARE

MANAGER

§ 4] Select a device/devices in the list.

§ 5] Right Mouse Click > Restore Factory Default Settings

[Wait for the reset process to end [usually it takes only seconds.]

Learn more »MADRIX HARDWARE MANAGER [USB / Ethernet]

Technical support might ask you to perform the following special command in rare cases:

Load Bootloader Only

§ 1] Disconnect all connections from the device [power, data, DMX].

§ 2] Use a suitable tool to press the reset button [between DMX 1 and 2].
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§ 3] Continue to press the reset button and supply power again over 'Power' or USB.

§ 4] Continue to press the reset button for 2 seconds.

§ 5] If successful, the status LED Power is blinking green.

Initiate Poll

During normal operation, quickly pressing the Reset button sends an Art-Net PollReply and a MADRIX

PollReply for device discovery to the network.
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2 Device Configuration

This topic includes:

§ Overview

§ Topics Of This Chapter

Overview

§ Web Configuration: The built-in web configuration is the main way of configuring your devices.

By using a standard web browser, you gain quick access to all device settings.

§ MADRIX HARDWARE MANAGER: This software is available separate. You can use it specifically

to manage MADRIX hardware products, including their basic configuration and firmware updates.

Topics Of This Chapter

§ Web Configuration [Ethernet]

§ MADRIX HARDWARE MANAGER [USB / Ethernet]

2.1 Web Configuration [Ethernet]

This topic includes:

§ Configuration Using A Web Browser
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Configuration Using A Web Browser

When connected to Ethernet network, you can easily configure MADRIX STELLA using the built-in

web configuration page.

You have 2 options to access the web interface. Both, STELLA and your computer, need to be in the

same network.

A] Using a standard web browser:

§ Connect MADRIX STELLA and your computer to the same network.

§ Assign correct network settings for your PC in the Windows operating system. 

[Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]

[Please note: Your devices and the sender, such as the PC that runs MADRIX 5, need to have

the same subnet mask!]

§ Open your web browser and enter the IP address of MADRIX STELLA.

[You can find the default IP address on the back side of the device.]

§ The web configuration page will be launched. Now, you have access to various information and

settings.

B] Using the MADRIX 5 Software:

§ Connect MADRIX STELLA and your computer to the same network.

§ Assign correct network settings for your PC in the Windows operating system. 

[Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]

[Please note: Your devices and the sender, such as the PC that runs MADRIX 5, need to have

the same subnet mask!]

§ Go to the menu Tools > MADRIX Device Configuration...

[Keyboard shortcut: Ctrl+Alt+L]

§ Select your MADRIX STELLA device in the list.

§ Click 

§ Your default web browser will open and the web configuration page will be launched. Now, you

have access to various information and settings.
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MADRIX STELLA automatically switches to input when receiving data [DMX-IN]. 

- Since this happens automatically, there is no need and no option to manually switch from

output to input.

- Make sure to 1] disable RDM and 2] set the option In Case Of Missing Network Data to Stop

Sending.

Please confirm any changes with Set

Device Name - Allows you to change the main label of the device by entering a

name. The default setting is MADRIX STELLA.

§ This refers to LongName within Art-Net with a maximum of 64

characters.

§ This refers to Source Name within sACN with a maximum of 63

characters.

§ This refers to the communication with the MADRIX 5 Software over

Ethernet network or USB.

Short Name (Art-Net) - Allows you to change the ShortName identifier

used by Art-Net. The default setting is the IP address of the device.

Confirm with Set

Network Address You can change the basic network device settings. 

Confirm with Set

§ IP Address

§ Subnet Mask

[Please note: Your devices and the sender, such as the PC that runs

MADRIX 5, need to have the same subnet mask!]

Network To DMX

Output

This section shows the network settings when using the DMX ports for

output [DMX 1 and DMX 2].

Confirm with Set

Assigned Network Universe - Defines the universe on which data is

sent. 
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§ By default, universe 1 and 2 assigned to DMX 1 and DMX 2.

§ If you are broadcasting data for a large number of Universes [using

Broadcast Mode instead of using Unicast Mode] with MADRIX 5 or a

3rd-party controller for example, you can assign different DMX

universes to each STELLA device with these settings. Each MADRIX

STELLA will then only receive data from the specific Art-Net universe

and send it to its specified output port. 

Example: You can set up that STELLA #1 only listens to Art-Net

universe 1 and 2, while STELLA #2 listens to Art-Net universe 3 and

4, and STELLA #3 listens to Art-Net universe 5 and 6, and so on.

§ Universes are shown in hexadecimal notation and Art-Net Net switch /

sub-net switch notation in the Network Universe tooltips.

Enable RDM - Allows the device to receive and send Remote Device

Management data on the specific port. 

§ Disable RDM on the specific port, when using STELLA for DMX-IN.

§ Only enable RDM if you wish to use it. Otherwise, disable RDM to

avoid any potential issues.

RDM UID Count - Shows the number of uniquely identified RDM devices

discovered and connected to the controller. 

§ May change continuously during an active RDM discovery process.

Device Accepts Network Data From - Defines the data source for the

device. Choose from the following options:

§  Art-Net

§ Streaming ACN

§ Art-Net And sACN
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Note: UCS512D can be controlled with MADRIX STELLA (with the RDM

functionality disabled).

DMX Output

Configuration

This section shows the settings for the DMX ports when used for output

[DMX 1 and DMX 2].

Confirm with Set

Channel Offset - Allows you to shift the received DMX universe [512 DMX

channels] per port if required.

§ This will modify the output.

§ +1 To +511 - Adding a positive channel offset will shift the received

channels to higher channel numbers. 

- Example: Received channel #1 will be shifted to channel #11 by

using a channel offset of 10.

- That means that new channels are added to the data [in front of

the received data block, with DMX value 0], while any channels that

now would be higher than 512 will be removed.

- Example, continued: Channels 1 to 10 are newly added, while

channels 503 to 512 are removed.

§ -1 To -511 - Adding a negative channel offset will shift the received

channels to lower channel numbers.

- Example: Received channel #512 will be shifted to channel #412 by

using a channel offset of -100.

- That means that the first channels will be removed. The frame will

be shorter.

- Example, continued: Channels 1 to 100 are now removed and the

frame has 412 channels in total.

§ Example: Your fixture should start with DMX channel 7.

- In the ideal case, you would set its DMX start address to 7. 

- If your fixture somehow is set to channel 6, you could increase its

start address by +1.

- Or you could shift the data that is sent by your device by -1 in

order to change the data from channel #7 to channel #6.
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[If you cannot change the fixture's settings or you cannot reach it

anymore, for example.]

§ Please note: According to the DMX512 standard, a minimum of 21

channels will always be sent.

§ A Channel Offset can have several advantages, such as splitting a

single universe onto multiple output ports.

- For example, your sender can only send on one universe and you

wish to output it on two ports. 

On DMX 1, you would like to send the first 150 channels and on DMX

2, you would like to send channels 151 to 300. 

Then, you can set both to the same universe and set a Channel

offset of 150 for DMX 2.

Channel Order - Allows you to change the order of [color] channels for

the output. 

§ For example, if you receive channels 1-2-3 [i.e. RGB, for example],

the setting 1-2-3-(4) will send it out as R-G-B. In contrast, the

setting 3-2-1 would send B-G-R. [Please only change this setting

when needed and when using simple, standard fixtures with RGB or

RGBW, for example.]

Send Full Frames - Activates that always 512 channels will be sent out. 

§ 512 channels are sent per frame even if the data that is received by

the device includes less than 512 channels for this port and universe. 

§ The device automatically sends values of 0 on channels that are not

used. 

Output Intensity - Sets the brightness level of the output towards the

LEDs by functioning as a dimmer.
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§ For example, when the device receives a DMX value of 255 on a

channel, this would be dimmed to 127 when the Output Intensity is

set to 50 %.

§ The minimum value is 1 %. The default value is 100 %.

§ Can be used alone or at the same time as Upper Intensity Limit. First,

the device applies the Output Intensity. Second, the Upper Intensity

Limit is applied.

Upper Intensity Limit - Sets the maximum brightness level that can be

sent. 

§ The minimum value is 1 %. The default value is 100 %.

§ Can be used alone or at the same time as Output Intensity. First, the

device applies the Output Intensity. Second, the Upper Intensity Limit

is applied.

In Case Of Missing Network Data - Allows you to specify the output

settings should the device not receive data for a specified DMX universe

[in both cases, when having never received data in the first place or when

the data is not being received anymore and a timeout is reached]. Choose

from the following options:

§ Send The Last Received Frame Continually

[Is true when data is not being received anymore and a timeout is

reached.]

[If no data is received at startup, black frames will be sent.]

§ Send Black Frames Continually

[Is true when data is not being received anymore and a timeout is

reached.]

[If no data is received at startup, black frames with value 0 will be

sent.]

§ Send White Frames Continually

[Is true when data is not being received anymore and a timeout is

reached.]



[Part 2] Device Configuration

//21www.madrix.com

MADRIX STELLA User Manual

[If no data is received at startup, white frames with value 255 will be

sent.]

§ Stop Sending After Sending A Black Frame

[Is true when data is not being received anymore and a timeout is

reached.]

[If no data is received at startup, black frames will be sent.]

§ Stop Sending

[Is true when data is not being received anymore and a timeout is

reached.]

[If no data is received at startup, there is also no output.]

Select this option if you wish to use DMX-IN!

DMX Input To

Network

This section allows you to specify settings for DMX input, which is sent

out to the network from the device.

Confirm with Set

When data is received, MADRIX STELLA will automatically forward it to

Ethernet network.

The device automatically switches to input when receiving data via

the DMX ports [DMX-IN].

- Since this happens automatically, there is no need and no option to

manually switch from output to input.

- Make sure to 1] disable RDM and 2] set the option In Case Of

Missing Network Data to Stop Sending.

If both output and input are sent to the device, the device will activate

the output.

Send Universe To Network - STELLA can receive 512 channels per port.

This setting defines on which universe those 512 channels are sent.

§ By default, 256 is set for DMX 1 and 255 is set for DMX 2. 

§ Valid values range from 1 to 32768.
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Always Send Full Frames To Network - Activates that always 512

channels will be sent out. 

§ 512 channels are sent per frame even if the data that is received by

STELLA includes less than 512 channels for this port and universe. 

§ STELLA automatically sends values of 0 on channels that are not

used. 

§ Art-Net Broadcast Mode - Sends Art-Net data to all IP addresses in

the network.

§ Art-Net Unicast Mode - Sends Art-Net data only to one recipient,

e.g. your MADRIX computer. Enter the IP address of your receiver

here.

§ sACN Multicast Mode - Sends Streaming ACN data to IP address

239.255.1.0 for port 1 and to IP address 239.255.0.255 for port 2.

Special Commands Reboot - Reboot System - Restarts the device completely. [The website

will automatically be reloaded after a few seconds.]

Reset - Reset To Factory Default Settings - Restores the original

settings of the device. [Since this may change back the IP address to the

original setting, the website will automatically be reloaded after a few

seconds and you will automatically be redirected to the correct website

and IP address.]

Device Information
§ Model 

[The device type.]

§ IP Address 

[The current IP address. Can be used as a click-able link to call the

device with this IP address.]

§ NetBIOS 

[An alternate way to call up the web configuration or find the device

in the network, and without using the IP address. Can also be used as

a click-able link to call the device with its NetBIOS name. Main
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workflow: Assuming correct network settings, simply type

http://SERIALNUMBER/ into your web browser, such as

http://STELLA000601/ ; often merely STELLA000601/ should

work. If you want to ping the device, use only STELLA000601]

§ MAC Address 

[A permanent, unique address.]

§ Serial Number

§ Firmware 

[The current firmware version.]

§ Bootloader 

[The current bootloader version.]

§ Hardware 

[The hardware revision.]

§ External Voltage

[The current voltage for External Power.]

§ System Temperature 

[The current ambient temperature inside the device case.]

§ Ethernet 

[The current status of the two Ethernet ports.]

§ Up Time 

[The time that has passed since the last power-cycle or restart.]

2.2 MADRIX HARDWARE MANAGER [USB / Ethernet]

This topic includes:

§ Overview

§ Device Configuration

§ Firmware Updates

§ More Information
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Overview

MADRIX HARDWARE MANAGER is a software tool that is available separately and allows you to manage

MADRIX hardware products.

It can be used for basic device configuration and to update the firmware of your device.

Download from »www.madrix.com

Important Information

§ Either use USB or the Ethernet connection!

When using both connection types devices will be shown with two different entries in the

list, which may lead to severe issues when accidentally updating the device over both

connections simultaneously.

https://www.madrix.com/
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§ Make sure to -stop- sending data to your devices when managing them with MADRIX

HARDWARE MANAGER.

This refers to input and/or output over Art-Net, sACN, DMX512, etc.

Otherwise, changes and updates might fail.

Device Configuration

Basic Configuration

§ 1] In MADRIX HARDWARE MANAGER, navigate to the Devices tab.

§ 2] You will see connected devices in a list including their current main settings.

§ 3] Basic settings can be changed and configured, including Name, IP Address, Subnet Mask,

Gateway, and more.

Open Web Configuration

§ 1] In MADRIX HARDWARE MANAGER, navigate to the Devices tab and select a

device/devices in the list.

§ 2] Right Mouse Click > Open Device Configuration Via HTTP... opens your standard web

browser and the built-in web configuration of the selected device.

§ Learn more »Web Configuration [Ethernet]

Restore Factory Default Settings

§ 1] In MADRIX HARDWARE MANAGER, navigate to the Devices tab and select a

device/devices in the list.

§ 2] Right Mouse Click > Restore Factory Default Settings restores the original settings of the

device.

[Since this may change back the IP address to the original setting, the website will automatically
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be reloaded after a few seconds and you will automatically be redirected to the correct website

and IP address.]

Firmware Updates

§ 1] In MADRIX HARDWARE MANAGER, navigate to the Firmware Files tab and make sure you

have the right [the latest] firmware version already downloaded and available. An active internet

connection is required.

§ 2] Go to the tab Devices and select a device/devices in the list.

§ 3] Navigate to the column Firmware and select the firmware you wish to install on the devices.

More Information

Please see the MADRIX HARDWARE MANAGER User Manual for more information. 

See »help.madrix.com

http://help.madrix.com/
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3 Using MADRIX 5 Software

This topic includes:

§ Overview

§ MADRIX 5 Software License

§ Operating Modes

§ Notes

§ DMX Watcher

Overview

The MADRIX STELLA works great in combination with the MADRIX 5 Software.

MADRIX 5 Software License

§ The MADRIX 5 Software license is not included and sold separately. A MADRIX 5 KEY is

necessary if you want to use output.

§ No separate license is required for DMX input [DMX-IN].

Operating Modes

You can mainly use 6 operating modes together with MADRIX 5 :

§ DMX-OUT Via Ethernet Network [Art-Net] 

§ DMX-OUT Via Ethernet Network [Streaming ACN / sACN] 

§ DMX-OUT Via USB
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§ DMX-IN Via Ethernet Network [Art-Net Remote]

§ DMX-IN Via Ethernet Network [Streaming ACN / sACN]

§ DMX-IN Via USB

Notes

§ DMX 1 can be configured as either DMX-IN or DMX-OUT.

§ DMX 2 can be configured as either DMX-IN or DMX-OUT.

§ You can use DMX 1 and DMX 2 at the same time.

DMX Watcher

DMX Watcher - Opens the DMX Watcher to monitor your DMX output or

input under Preferences > Device Manager... > DMX Devices

3.1 Output [Art-Net]

This topic includes:

§ DMX-OUT Via Ethernet Network [Art-Net]

§ 1] Initial Configuration

§ 2] Windows Network Settings

§ 3] Fixture Patching In MADRIX 5

§ 4] Activating Art-Net

§ 5] Adding Devices Automatically

§ 6] Activating Devices

§ 7] Configuration Of DMX Output

§ 8] Frame Time
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§ 9] Optimized Frames Or Full Frames

§ 10] Sync Mode

§ Additional Art-Net Device Settings

DMX-OUT Via Ethernet Network [Art-Net]

You can connect the STELLA over Ethernet network to the network card of your computer that runs

the MADRIX 5 Software. Data is distributed to the STELLA over network cabling [Ethernet] and sent

to the two ports [DMX 1 and DMX 2].

1] Initial Configuration

§ Put MADRIX STELLA into operation; as described above. Learn more »Putting The Device Into

Operation 

§ Connect MADRIX STELLA to your computer using Ethernet network cabling.

§ It is highly recommended to use Gigabit Ethernet network components [network card, switches,

etc.].

§ Set up the corresponding settings in the »Configuration Using A Web Browser

2] Windows Network Settings

Art-Net is a network-based protocol. MADRIX 5 will use the network card of your computer to send

data. 

§ It is required to set up the correct network settings in Windows, first.

§ You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not

work!
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§ The IP addresses of your computer and your MADRIX STELLA devices need to be

different.

§ Set up an individual IP address in the following IP address range:

- 2.0.0.1 ... 2.255.255.254 or

- 10.0.0.1 ... 10.255.255.254

§ Set up the corresponding Subnet mask

- 255.0.0.0

[Via factory default settings, MADRIX STELLA devices will have an IP address in the

10.x.x.x network range, such as 10.78.0.86, for example].

[Please note: Your devices and the sender, such as the PC that runs MADRIX 5, need to

have the same subnet mask!]

§ Restart MADRIX 5, if you have changed the network settings in Windows while MADRIX 5

was running.

§ Learn more »Tips [Microsoft Windows / Networks / USB] 

§ Example for PCs that are running MADRIX 5 :
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3] Fixture Patching In MADRIX 5

§ Start the MADRIX 5 Software.

§ Configure the virtual LED matrix using the Matrix Generator or Patch Editor.

4] Activating Art-Net

§ Go to the menu Preferences > Device Manager... > Art-Net 

[Keyboard shortcut: F4 > Art-Net]

§ Activate the checkbox Enable [in the upper, right corner].
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5] Adding Devices Automatically

MADRIX 5 can automatically add your MADRIX STELLA devices.

§ Click 

[MADRIX 5 will automatically search the network for connected MADRIX STELLA devices. Devices

that are found will appear in the list. One entry will be created for each input universe and

output universe.]
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6] Activating Devices

Each of your MADRIX STELLA devices and its ports need to be activated. By default, they are still

deactivated.
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§ Go to the menu Preferences > Device Manager... > DMX Devices 

[Keyboard shortcut: F4]

§ Select your devices and their ports in the list.

§ Right Mouse Click on the column State to set from Off to On [indicated by green light].

§ OUT and IN are set by default for the corresponding ports and universes.
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§ [In the screenshot above, one STELLA is connected. If more devices are connected, please use

the different IP addresses of different devices to identify them in the Device Manager.]

7] Configuration Of DMX Output

§ Make sure that your output port is still selected under Preferences > Device Manager... >

DMX Devices

§ When using your device as an output device, set up Universe

- Right Mouse Click or Left Mouse Double-Click on the column Universe and enter the

required number.

§ This setting assigns a specific DMX universe [of the Patch] to the device or the port of the

device.

§ Make sure to assign the correct universe according to your requirements.

Learn more »Glossary

§ By default, DMX universe 1 is assigned to DMX 1 and DMX universe 2 is assigned to DMX 2.
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8] Frame Time

§ Make sure that your device is still selected under Preferences > Device Manager... > DMX

Devices

§ Set up the frame time for your device.

- Right Mouse Click or Left Mouse Double-Click on the column ms / FPS and enter the

required number.

- The frame time [in milliseconds; ms] affects the frame rate. The frame rate specifies how fast

data is sent to the device or received from it [in Frames Per Second; FPS].

- Increase the frame time in order to decrease the frame rate [e.g., 40 ms = 25 FPS].

- Decrease the frame time in order to increase the frame rate [e.g., 20 ms = 50 FPS].

- The default value is 30 ms / 33.3 FPS.

- The minimum value is 1000 ms / 1 FPS. 

- The maximum value is 5 ms / 200 FPS. 

   Please note: If you want to output high frame rates, make sure to set Main Mixing FPS in the

Options to the same value in order to render the same frame rate [It is set to 50 FPS by default.

Otherwise, frames will be duplicated].

   Please note: If you want to input high frame rates, make sure to set DMX Controller Input FPS

in the Options to the same value in order to process the same frame rate [It is set to 50 FPS by

default. Otherwise, frames will be duplicated].

- Some LED fixtures might have problems with a low frame time / high frame rate. Then,

it is recommended to increase the frame time / decrease the frame rate.

§ [When using Art-Net, the Frame Time [ms] can be individually set for each port. But it cannot be

set individually for each port, when Sync Mode is activated. Learn more below.]

9] Optimized Frames Or Full Frames

§ Make sure that your device is still selected under Preferences > Device Manager... > DMX

Devices



[Part 3] Using MADRIX 5 Software

//38www.madrix.com

MADRIX STELLA User Manual

§ Choose how to send data.

- Right Mouse Click or Left Mouse Double-Click on the column Frames to choose between

Optimized and Full

- Per DMX512 standard, MADRIX 5 only sends the number of DMX channels that is configured

[optimized frames]. For example, if you are using 312 DMX channels on a DMX universe, only 312

DMX channels will be sent with every single frame on this universe.

- Activate Full Frames if devices should always send full frames on a particular universe, instead

of optimized frames. Sending full frames means that always the full 512 DMX channels of a DMX

universe will be sent with every frame [even when you are using less than 512 channels on the

universe].

- Activating Full Frames is recommended if problems with the data output of your

devices occur.

§ In addition, you can activate Full Frames for the device and each MADRIX STELLA port

separately in the Device Configuration.

10] Sync Mode

MADRIX STELLA can use the special sync mode of Art-Net. 

§ Large LED projects require dependable data distribution. The MADRIX 5 Software and STELLA

hardware allow you to fully synchronize data output for all output DMX ports and even across

multiple STELLA devices to get an optimal image on the LEDs.

§ When Art-Net sync mode is activated, MADRIX 5 and MADRIX STELLA will automatically handle

the synchronization of data.

Art-Net Sync Mode is highly recommended for MADRIX STELLA!

ArtSync - Allows you to activate or deactivate the usage of

synchronisation commands/packages for Art-Net. 

- Your Art-Net devices need to support this feature in order for it to work
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correctly.

- All MADRIX hardware Art-Net nodes support ArtSync.

- Sync packages will be sent to all network cards for which corresponding

Art-Net nodes are created in the MADRIX 5 Software.

In addition, you can choose between Post-Sync [default] and Pre-Sync.

By default, the sync data is sent after the main DMX/Art-Net data. Pre-

Sync would send it before the main DMX/Art-Net data.

§ Before activating sync, make sure that all activated Art-Net

devices are available in your network! Else, the frame rate of Art-

Net might drop. If you are not sure, do not enable any sync mode.

§ Disable ArtSync if you wish to HTP merge from two sources!

ArtSync would then interfere with the merge and create unwanted

results.

Additional Art-Net Device Settings

It is very important to set up the correct settings of your devices!

Broadcast Mode Or Unicast Mode

MADRIX 5 can send Art-Net data in 2 ways to your Art-Net devices:

§ Broadcast Mode - Means that every packet sent from a single transmitter will be received by all

recipients in the network. MADRIX 5 will send data to all devices in the network.

- Advantage: The same data [e.g., DMX universe 1 and 2] can be made available at different

points of your setup.

- Disadvantage: A potentially huge number of data packages will be sent over the network. This

can reduce the overall network performance and cause data issues or instability.
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§ Unicast Mode - Means that the specific data will only be sent to the specified recipient.

- Advantage: Data traffic is reduced immensely, which means that a larger number of Art-Net

devices can be used in one network. Reduced network traffic increases the performance and

stability.

- Disadvantage: The network settings of all devices need to be 100% correct.

Unicast Mode is recommended in general.

§ Go to the menu Preferences > Device Manager... > Art-Net 

[Keyboard shortcut: F4 > Art-Net]

§ Select your device in the list.

§ Click 

§ A new window will open.

§ A] Choose Send Unicast Mode to activate Unicast Mode:

- Make sure to enter the correct IP Address of your device that should receive the Art-Net

data.

- MADRIX 5 will send the corresponding data only to this device.

§ B] Choose Send Broadcast Mode to activate Broadcast Mode:

- Make sure to select the correct Network card of your computer that should send the Art-Net

data.

- MADRIX 5 will send data to the whole Art-Net network.

§ Click Apply

Status Indicators [ArtAddress]

In order to use these features, Enable ArtAddress first.

§ Regarding sending ArtAddress commands to nodes, make sure that your nodes fully support this

Art-Net feature.

You will also get notified by a message box. Confirm the message with OK or abort via Cancel.

§ MADRIX LUNA, MADRIX NEBULA, MADRIX PLEXUS, MADRIX STELLA, MADRIX ORION, and MADRIX

AURA support ArtAddress.
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§ MADRIX 5 itself can receive ArtAddress commands.

Mute Status Indicators - Switches off and disables all built-in status

indicators of a device over Art-Net [ArtAddress > AcLedMute].

Operate Status Indicators Normally - Allows the built-in status

indicators of a device to operate normally again, after having them

switched off [ArtAddress > AcLedNormal].

Highlight Device - Activates the highlight mode [ArtAddress >

AcLedLocate]. Select one or more interfaces and click the button. The

corresponding status indicators of the selected interfaces will flash for a

better identification or tests. This makes it easier to see them on

site/stage. It considerably speeds up the procedure of programming or

testing the selected interfaces. 

In addition to sending out commands to nodes, MADRIX 5 itself can

receive ArtAddress commands.

Receive - Activates that MADRIX 5 is able to receive ArtAddress

commands. It is enabled by default.

§ AcLedMute and AcLedNormal will disable the identification of MADRIX

5.

§ AcLedLocate will enable the identification of MADRIX 5.

- As long as Identify is enabled or set via protocol commands, the

MADRIX 5 user interface [GUI] will repeatedly change every second

from the currently selected theme to the opposite theme, either from

dark to light or vice versa. 

- This visibly highlights the user interface for visual identification of

this MADRIX 5 instance as a device within a network system.

- Identify will also be deactivated when manually switching the

theme, either via the menu [View > Theme > Light/Dark] or its

keyboard shortcut [Ctrl+T].
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You can further customize ArtAddress properties under menu Preferences

> Options... > General

3.2 Output [sACN]

This topic includes:

§ DMX-OUT Over Ethernet Network [Streaming ACN / sACN]

§ 1] Initial Configuration

§ 2] Windows Network Settings

§ 3] Fixture Patching In MADRIX 5

§ 4] Activating Streaming ACN

§ 5] Activating Devices

§ 6A] Configuration Of Single Devices

§ 6B] Configuration Of Multiple Devices

§ 7] Frame Time

§ 8] Optimized Frames Or Full Frames

DMX-OUT Over Ethernet Network [Streaming ACN /

sACN]

You can connect the STELLA over Ethernet network to the network card of your computer that runs

the MADRIX 5 Software. Data is distributed to the device over network cabling [Ethernet] and sent to

the output ports [DMX 1 and DMX 2].

1] Initial Configuration

§ Put MADRIX STELLA into operation; as described above. Learn more »Putting The Device Into

Operation 
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§ Connect MADRIX STELLA to your computer using Ethernet network cabling.

§ It is highly recommended to use Gigabit Ethernet network components [network card, switches,

etc.].

§ Set up the corresponding settings in the »Configuration Using A Web Browser

2] Windows Network Settings

§ MADRIX 5 automatically sets up Streaming ACN network settings for you.

[MADRIX 5 supports multicast Streaming ACN. Data is automatically sent to all corresponding

sACN devices in the network. Unicast is also supported.] 

§ You only need a computer with a network card and a valid IP address.

§ You do not have to change the IP address settings in Windows for Streaming ACN!

§ The IP address range for sACN devices is 239.255.X.X according to the Streaming ACN

specifications. MADRIX STELLA automatically works this way.

§ Make sure that your Firewall does not block data of the 239.255.X.X IP address range!

§ Check the settings of the Windows Firewall. 

§ Learn more »Tips [Microsoft Windows / Networks / USB] 

3] Fixture Patching In MADRIX 5

§ Start MADRIX 5.

§ Configure the virtual LED matrix using the Matrix Generator or Patch Editor.
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4] Activating Streaming ACN

§ Go to the menu Preferences > Options... > Devices Network

[Keyboard shortcut: Ctrl+Alt+O > Devices Network]

§ Activate ESTA - Streaming ACN

§ Choose your network card from the drop-down list. Make sure to select the correct network

adapter that will be used for Streaming ACN!

[The IP address and Subnet mask label should help you select the correct adapter. It is not

necessary to change any of these networks settings.]

§ ACN Device Count - Set up how many you are going to use. MADRIX STELLA requires 2 sACN

devices per unit.

[This is the total amount of devices. Please set the exact number of devices you are using. If

the count is higher, this creates unnecessary network traffic.]

§ Click Apply

§ ACN CID - Being a network protocol, Streaming ACN sends a so-called CIDs [Component

Identifier].
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- Every single ACN device has such a unique ID.

- When using Streaming ACN, your MADRIX 5 Software is one of those devices.

- When you start MADRIX 5 for the first time, this ID will be generated automatically for you.

From this point onwards it will be used on your PC.

- With this ID your MADRIX 5 Software can be easily identified in the network. Interfaces can

detect this unique ID and can be configured to receive data from this particular device. Please

note that the ACN interface must support this feature.

- Do not change the ACN CID, unless you are an experienced user!

§ Click OK to close the window.

5] Activating Devices

Each of the ports need to be activated if that is not already the case.

§ Go to the menu Preferences > Device Manager... > DMX Devices 

[Keyboard shortcut: F4]

§ Select your devices and their ports in the list. 2 output universes will be shown.

§ Right Mouse Click on the column State to set from Off to On [indicated by green light]. By

default, the devices are already activated.



[Part 3] Using MADRIX 5 Software

//46www.madrix.com

MADRIX STELLA User Manual

§ [In the screenshot above, one STELLA is connected. If more devices are connected, please use

the different universes of different devices and the device details [i] to identify them in the

Device Manager.]

§ Universe - Defines which universe of your MADRIX 5 Patch is sent to this particular device.

- Right Mouse Click on the column Universe in order to enter a different number.

6A] Configuration Of Single Devices

§ Select a device in the list and click 
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§ A new window will open.

Set up the following settings for your devices:

§ Source Name - Allows you to set up a specific name for the device. This name is send via

network as well. Therefore, interfaces may be able to retrieve this name and can be configured

to receive data from this source.

- If you are using the default name MADRIX U:X, the universe will automatically be displayed in

the name [represented by X: 1, 2, 3, etc.].
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§ ACN Universe - Defines the DMX universe of the device. 

- Set up the same universe that is set up in your sACN device, which is MADRIX STELLA.

- According to the Streaming ACN specifications, MADRIX 5 will automatically change the ACN IP

Address according to the ACN Universe.

§ ACN Priority - Was implemented for backup solutions. Valid values range from 0 to 200, which is

the highest priority.

- For example, you may have set up two MADRIX PCs. One gets a priority of 100. The second PC

gets a priority of 50. If the first PC fails and only if it malfunctions, data will be automatically

received from PC #2.

- Data will always be received from the device with the highest priority. Please note that the

ACN device must support this feature.

§ ACN Protocol - Automatically selects the ANSI 2009 standard.

§ Use Multicast

ACN Multicast IP Address - Displays the IP address of the device as automatically assigned by

MADRIX 5 according to the Streaming ACN specifications. The last 2 digits match the assigned

DMX universe.

§ Use Unicast

ACN Unicast IP Address - Uses a specific IP address to send data to.

§ Click Apply to confirm your changes.

§ Click OK to close the window.

6B] Configuration Of Multiple Devices

§ You can configure several interfaces at the same time.

§ Follow the steps of 6A, but select multiple devices and click 

§ A new window will open.
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§ Set up the settings as described under 6A].

§ For ACN Universe, you have now additional options for Numbering:

Click the button and MADRIX 5 will automatically increase the ACN Universe number for

all the selected devices [which can be seen in the DMX Devices tab of the Device Manager],

starting with the value you have entered.

§ Click Apply and OK to confirm your changes.

7] Frame Time

§ Make sure that your device is still selected under Preferences > Device Manager... > DMX

Devices

§ Set up the frame time for your device.

- Right Mouse Click or Left Mouse Double-Click on the column ms / FPS and enter the

required number.

- The frame time [in milliseconds; ms] affects the frame rate. The frame rate specifies how fast

data is sent to the device or received from it [in Frames Per Second; FPS].

- Increase the frame time in order to decrease the frame rate [e.g., 40 ms = 25 FPS].

- Decrease the frame time in order to increase the frame rate [e.g., 20 ms = 50 FPS].
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- The default value is 30 ms / 33.3 FPS.

- The minimum value is 1000 ms / 1 FPS. 

- The maximum value is 5 ms / 200 FPS. 

   Please note: If you want to output high frame rates, make sure to set Main Mixing FPS in the

Options to the same value in order to render the same frame rate [It is set to 50 FPS by default.

Otherwise, frames will be duplicated].

   Please note: If you want to input high frame rates, make sure to set DMX Controller Input FPS

in the Options to the same value in order to process the same frame rate [It is set to 50 FPS by

default. Otherwise, frames will be duplicated].

- Some LED fixtures might have problems with a low frame time / high frame rate. Then,

it is recommended to increase the frame time / decrease the frame rate.

8] Optimized Frames Or Full Frames

§ Make sure that your device is still selected under Preferences > Device Manager... > DMX

Devices

§ Choose how to send data.

- Right Mouse Click or Left Mouse Double-Click on the column Frames to choose between

Optimized and Full

- Per DMX512 standard, MADRIX 5 only sends the number of DMX channels that is configured

[optimized frames]. For example, if you are using 312 DMX channels on a DMX universe, only 312

DMX channels will be sent with every single frame on this universe.

- Activate Full Frames if devices should always send full frames on a particular universe, instead

of optimized frames. Sending full frames means that always the full 512 DMX channels of a DMX

universe will be sent with every frame [even when you are using less than 512 channels on the

universe].

- Activating Full Frames is recommended if problems with the data output of your

devices occur.

3.3 Output [USB]

This topic includes:

§ DMX-OUT Via USB
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§ 1] Initial Configuration

§ 2] Fixture Patching In MADRIX 5

§ 3] Enabling Drivers

§ 4] Activating Devices

§ 5] Configuration Of DMX Output

§ 6] Frame Time

§ 7] Optimized Frames Or Full Frames

DMX-OUT Via USB

You can connect the STELLA directly over USB to the computer that runs the MADRIX 5 Software.

Data is distributed to the MADRIX STELLA via USB and sent to the two ports [DMX 1 and DMX 2].

1] Initial Configuration

§ Put MADRIX STELLA into operation by connecting the LED fixtures and supplying power; as

described above. Learn more »Putting The Device Into Operation 

§ Connect MADRIX STELLA to your computer via USB.

[Use the provided USB cable.]

§ Make sure to check the power-management options of Windows. Learn more »PC Power

Management

2] Fixture Patching In MADRIX 5

§ Start MADRIX 5.

§ Configure the virtual LED matrix using the Matrix Generator or Patch Editor.
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3] Enabling Drivers

§ Go to the menu Preferences > Options... > Devices USB 

[Keyboard shortcut: Ctrl+Alt+O > Devices USB]

§ Activate MADRIX STELLA

§ Click Apply

§ Close the window with OK

4] Activating Devices

§ Go to the menu Preferences > Device Manager... > DMX Devices 

[Keyboard shortcut: F4]

§ Your STELLA devices and their two ports will appear in the list.
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§ If your devices are not in the list, click 

[In the screenshot below, one STELLA is connected.]

§ By default, all ports are activated [State On].

§ If your device and ports are not activated, do the following:

§ Select the device/port in the list.

§ Right Mouse Click on the column State to set from Off to On [indicated by green light].

§ Right Mouse Click on the column OUT / IN to set to OUT for data output.

5] Configuration Of DMX Output

§ Make sure that your devices are still selected under Preferences > Device Manager... > DMX

Devices

§ When using your device as an output device, set up Universe

- Right Mouse Click or Left Mouse Double-Click on the column Universe and enter the

required number.

§ This setting assigns a specific DMX universe [of the Patch] to the device or the port of the

device.



[Part 3] Using MADRIX 5 Software

//54www.madrix.com

MADRIX STELLA User Manual

§ Make sure to assign the correct universe according to your requirements.

Learn more »Glossary

§ By default, DMX universe 1 is assigned to DMX 1 and DMX universe 2 is assigned to DMX 2.

6] Frame Time

§ Make sure that your device is still selected under Preferences > Device Manager... > DMX

Devices

§ Set up the frame time for your device.

- Right Mouse Click or Left Mouse Double-Click on the column ms / FPS and enter the

required number.

- The frame time [in milliseconds; ms] affects the frame rate. The frame rate specifies how fast

data is sent to the device or received from it [in Frames Per Second; FPS].

- Increase the frame time in order to decrease the frame rate [e.g., 40 ms = 25 FPS].

- Decrease the frame time in order to increase the frame rate [e.g., 20 ms = 50 FPS].

- The default value is 30 ms / 33.3 FPS.

- The minimum value is 1000 ms / 1 FPS. 

- The maximum value is 5 ms / 200 FPS. 

   Please note: If you want to output high frame rates, make sure to set Main Mixing FPS in the

Options to the same value in order to render the same frame rate [It is set to 50 FPS by default.

Otherwise, frames will be duplicated].

   Please note: If you want to input high frame rates, make sure to set DMX Controller Input FPS

in the Options to the same value in order to process the same frame rate [It is set to 50 FPS by

default. Otherwise, frames will be duplicated].

- Some LED fixtures might have problems with a low frame time / high frame rate. Then,

it is recommended to increase the frame time / decrease the frame rate.

§ [When using USB, the frame time will be automatically set to the same value for all output

ports.]
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7] Optimized Frames Or Full Frames

§ Make sure that your device is still selected under Preferences > Device Manager... > DMX

Devices

§ Choose how to send data.

- Right Mouse Click or Left Mouse Double-Click on the column Frames to choose between

Optimized and Full

- Per DMX512 standard, MADRIX 5 only sends the number of DMX channels that is configured

[optimized frames]. For example, if you are using 312 DMX channels on a DMX universe, only 312

DMX channels will be sent with every single frame on this universe.

- Activate Full Frames if devices should always send full frames on a particular universe, instead

of optimized frames. Sending full frames means that always the full 512 DMX channels of a DMX

universe will be sent with every frame [even when you are using less than 512 channels on the

universe].

- Activating Full Frames is recommended if problems with the data output of your

devices occur.

§ In addition, you can activate Full Frames for the device and each MADRIX STELLA port

separately.

3.4 Input [Art-Net]

This topic includes:

§ DMX-IN Via Ethernet Network [Art-Net Remote]

§ 1] Initial Configuration

§ 2] Windows Network Settings

§ 3] Activating Art-Net

§ 4] Adding Devices Automatically

§ 5] Configuration Of Art-Net Input

§ 6] Activating Your Art-Net Input Device

§ 7] Activating DMX Input

§ 8] Art-Net Remote
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DMX-IN Via Ethernet Network [Art-Net Remote]

You can connect MADRIX STELLA over Ethernet network to the network card of your computer that

runs the MADRIX 5 Software. Data is sent to the STELLA via a port and from the STELLA to MADRIX 5

via Ethernet network.

1] Initial Configuration

§ Connect your external DMX controller to the DMX port of MADRIX STELLA.

§ Connect MADRIX STELLA to power.

[Please see safety instructions in the MADRIX STELLA Technical Manual & Quick Start Guide!]

§ Connect MADRIX STELLA to your computer via network cabling.

§ It is highly recommended to use Gigabit Ethernet network components [network card, switches,

etc.].

§ Set up the corresponding settings in the »Configuration Using A Web Browser

2] Windows Network Settings

Art-Net is a network-based protocol. MADRIX 5 will use the network card of your computer to send

data. 

§ It is required to set up the correct network settings in Windows, first.

§ You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not

work!

§ The IP addresses of your computer and your MADRIX STELLA devices need to be

different.
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§ Set up an individual IP address in the following IP address range:

- 2.0.0.1 ... 2.255.255.254 or

- 10.0.0.1 ... 10.255.255.254

§ Set up the corresponding Subnet mask

- 255.0.0.0

[Via factory default settings, MADRIX STELLA devices will have an IP address in the

10.x.x.x network range, such as 10.78.0.86, for example].

[Please note: Your devices and the sender, such as the PC that runs MADRIX 5, need to

have the same subnet mask!]

§ Restart MADRIX 5, if you have changed the network settings in Windows while MADRIX 5

was running.

§ Learn more »Tips [Microsoft Windows / Networks / USB] 

3] Activating Art-Net

§ Go to the menu Preferences > Device Manager... > Art-Net 

[Keyboard shortcut: F4 > Art-Net]

§ Activate the checkbox Enable [in the upper, right corner].
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4] Adding Devices Automatically

MADRIX 5 can automatically add your MADRIX STELLA devices.

§ Click 

[MADRIX 5 will automatically search the network for connected MADRIX STELLA devices. Devices

that are found will appear in the list. One entry will be created in the list for each STELLA

device.]
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5] Configuration Of Art-Net Input

§ Select your STELLA device in the list with one of its inputs.
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§ Click 

§ A new window opens [Art-Net Device Configuration].

§ Universe Port IN 

- By default, MADRIX STELLA sends DMX-IN data to universe 256 for Port 1 and to

universe 255 for Port 2. You can change these settings in the Web Configuration or

MADRIX Device Configuration window if required.

- If you have changed the settings, enter the exact same network universes here!

§ Activate Receive Direct IP Mode and enter the IP Address of your MADRIX STELLA. Confirm

with Apply

[E.g., 10.78.2.89]
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§ [You can also activate Receive Broadcast Mode. In this mode, MADRIX 5 will receive any DMX

data that is sent in the network on this particular Art-Net universe.]

§ Click OK

6] Activating Your Art-Net Input Device

You need to activate the Art-Net input device. It is still deactivated.

§ Go to the menu Preferences > Device Manager... > DMX Devices 

[Keyboard shortcut: F4]

§ Select the STELLA device in the list per its port. 

[You can activate both input ports at the same time.]

§ Right Mouse Click on the column State to set from Off to On [indicated by green light].

§ IN is automatically activated.
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§ If required, change the frame time.

- Right Mouse Click or Left Mouse Double-Click on the column ms / FPS and enter the required

number.

- The frame time [in milliseconds; ms] affects the frame rate. The frame rate specifies how fast

data is sent to the device or received from it [in Frames Per Second; FPS].

- Increase the frame time in order to decrease the frame rate [e.g., 40 ms = 25 FPS].

- Decrease the frame time in order to increase the frame rate [e.g., 20 ms = 50 FPS].

- The default value is 30 ms / 33.3 FPS.

- The minimum value is 1000 ms / 1 FPS. 

- The maximum value is 5 ms / 200 FPS. 

   Please note: If you want to output high frame rates, make sure to set Main Mixing FPS in the

Options to the same value in order to render the same frame rate [It is set to 50 FPS by default.

Otherwise, frames will be duplicated].

   Please note: If you want to input high frame rates, make sure to set DMX Controller Input FPS in

the Options to the same value in order to process the same frame rate [It is set to 50 FPS by

default. Otherwise, frames will be duplicated].

- Some LED fixtures might have problems with a low frame time / high frame rate. Then, it

is recommended to increase the frame time / decrease the frame rate.
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7] Activating DMX Input

§ Go to the menu Preferences > Device Manager... > DMX Input

§ Select your preferred DMX Universe in the list.

[By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN

universes, you can change the setting under menu Preferences > Options... > Performance]

§ Choose your DMX-IN Device in the section Device. Select the Art-Net input device via its IP

address.
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§ Art-Net input is now activated. MADRIX 5 can already receive DMX data.

§ Now, choose how to use incoming data as explained below.

8] Art-Net Remote

Data

§ At this point, MADRIX 5 is now already receiving any incoming data.

§ You can now use this data, for example for Scripts and Macros.

§ If you want to monitor incoming signals, select your DMX universe/DMX device in the list and

click 

Mapping

§ Use Mapping, if you want to route incoming DMX signals through MADRIX 5 to your output [DMX-

Thru].
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§ First, select your device in the list.

§ Activate Mapping

§ This feature maps incoming data to the specified DMX universe and channels.

§ Configure the following settings in the section Mapping

- Map Channels From - Defines which incoming channels are used. This is the start channel to

specify the range of channels.

- To - Defines which incoming channels are used. This is the end channel to specify the range of

channels.

- To Universe - Defines onto which output DMX universe MADRIX 5 should map the specified

range of incoming channels.

- Start At Channel - Defines the first DMX channel of the output DMX universe MADRIX 5 should

use.

- Use HTP - Activates the Highest Takes Precedence feature. You can map incoming data to a

DMX address range that MADRIX 5 already controls. Use HTP and MADRIX 5 will compare

incoming values with the DMX data it sends to the DMX output. As a result, MADRIX 5 will only

use the highest of both values on a particular channel and send it to the output.

§ Click Apply to confirm.
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Remote Control

§ Use Remote Control, if you want to control the MADRIX 5 Software remotely

§ First, select your device in the list.

§ Activate Remote

§ Select one of the built-in protocols in the section Remote Control as explained below

or create your own remote configuration.

Open - Loads a previously saved MADRIX 5

DMX Remote Configuration file [of the file type

*.mdrx].

Protocols - Choose from a pre-configured

protocol [configuration].
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DMX-IN Remote Editor - Allows you to modify

a configuration or create a new configuration. 

Start Address - Defines on which particular

DMX channel the protocol should start. The

whole protocol will be mapped to this new

address area.

DMX Watcher - Opens the DMX Watcher to

monitor your DMX output or input.

Trigger

§ Use Trigger, if you want to use incoming signals for the MADRIX 5 TRI Effects.

§ First, select your device in the list.

§ Activate Trigger
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Port - Defines the port [Port 1 - 8] that is

assigned to this DMX-IN Device. MADRIX 5 allows

you to send trigger signals from up to 8 different

devices [8 ports] and assign a MADRIX 5 TRI

Effect the corresponding port.

Value Range - Defines the range of incoming

DMX values that can be used as trigger signal.

- The minimum and default value is 1. 

- The maximum and default value is 512.

Assign Minimum Value - Automatically assigns

the minimum value when using the controller.

- Click Assign and use the control on your

controller for the minimum value and the value

will be set automatically in the MADRIX 5

Software.

Assign Maximum Value - Automatically assigns

the maximum value when using the controller.

- Click Assign and use the control on your

controller for the maximum value and the value

will be set automatically in the MADRIX 5

Software.

3.5 Input [sACN]

This topic includes:

§ DMX-IN Via Ethernet Network [Streaming ACN / sACN]

§ 1] Initial Configuration

§ 2] Windows Network Settings
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§ 3] Activating Streaming ACN

§ 4] Enabling Input

§ 5] Configure Your Device

§ 6] Enable DMX-IN

§ 7] sACN Input

DMX-IN Via Ethernet Network [Streaming ACN / sACN]

You can connect MADRIX STELLA over Ethernet network to the network card of your computer that

runs the MADRIX 5 Software. Data is sent to the STELLA via a port and from the STELLA to the

MADRIX 5 via Ethernet network.

1] Initial Configuration

§ Connect your external DMX controller to the DMX port of MADRIX STELLA.

§ Connect MADRIX STELLA to power.

[Please see safety instructions in the MADRIX STELLA Technical Manual & Quick Start Guide!]

§ Connect MADRIX STELLA to your computer via network cabling.

§ It is highly recommended to use Gigabit Ethernet network components [network card, switches,

etc.].

§ Set up the corresponding settings in the »Configuration Using A Web Browser

2] Windows Network Settings

§ MADRIX 5 automatically sets up Streaming ACN network settings for you.

§ You only need a computer with a network card and a valid IP address.
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§ You do not have to change the IP address settings in Windows for Streaming ACN!

§ The IP address range for sACN devices is 239.255.X.X according to the Streaming ACN

specifications.

[Even if your sACN devices are set to a different IP address range, you may try the

connection from MADRIX 5 to your devices.]

§ Make sure that your Firewall does not block data of the 239.255.X.X IP address range!

§ Check the settings of the Windows Firewall. 

§ Learn more »Tips [Microsoft Windows / Networks / USB] 

3] Activating Streaming ACN

§ Go to the menu Preferences > Options... > Devices Network

[Keyboard shortcut: Ctrl+Alt+O > Devices Network]

§ Activate ESTA - Streaming ACN

§ Choose your network card from the drop-down list. Make sure to select the correct network

adapter that will be used for Streaming ACN!

[The IP address and Subnet mask label should help you select the correct adapter. It is not

necessary to change any of these networks settings.]

§ ACN Device Count - Set up how many you are going to use.

[This is the total amount of OUT and IN devices. Please set the exact number of devices you are

using. If the count is higher, this creates unnecessary network traffic.]

§ Click Apply
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§ ACN CID - Being a network protocol, Streaming ACN sends a so-called CIDs [Component

Identifier].

- Every single ACN device has such a unique ID.

- When using Streaming ACN, your MADRIX 5 Software is one of those devices.

- When you start MADRIX 5 for the first time, this ID will be generated automatically for you.

From this point onwards it will be used on your PC.

- With this ID your MADRIX 5 Software can be easily identified in the network. Interfaces can

detect this unique ID and can be configured to receive data from this particular device. Please

note that the ACN interface must support this feature.

- Do not change the ACN CID, unless you are an experienced user!

§ Click OK to close the window.
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4] Enabling Input

§ Go to Preferences > Device Manager... > DMX Devices

[Keyboard shortcut: F4]

§ MADRIX 5 automatically creates and adds the number of interfaces to the list.

[according to ACN Device Count]

§ Select your device.

§ Right Mouse Click on the column OUT / IN to set to IN for data input if you wish to receive

incoming data through this device.

§ In DMX-IN mode, you will not be able to select the ACN protocol. MADRIX 5 will automatically

select the correct protocol version.

§ Set up the frame time for your device.

- Right Mouse Click or Left Mouse Double-Click on the column ms / FPS and enter the

required number.

- The frame time [in milliseconds; ms] affects the frame rate. The frame rate specifies how fast

data is sent to the device or received from it [in Frames Per Second; FPS].

- Increase the frame time in order to decrease the frame rate [e.g., 40 ms = 25 FPS].

- Decrease the frame time in order to increase the frame rate [e.g., 20 ms = 50 FPS].

- The default value is 30 ms / 33.3 FPS.

- The minimum value is 1000 ms / 1 FPS. 

- The maximum value is 5 ms / 200 FPS. 

   Please note: If you want to output high frame rates, make sure to set Main Mixing FPS in the

Options to the same value in order to render the same frame rate [It is set to 50 FPS by default.

Otherwise, frames will be duplicated].

   Please note: If you want to input high frame rates, make sure to set DMX Controller Input FPS

in the Options to the same value in order to process the same frame rate [It is set to 50 FPS by

default. Otherwise, frames will be duplicated].

- Some LED fixtures might have problems with a low frame time / high frame rate. Then,

it is recommended to increase the frame time / decrease the frame rate.
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§ Note: If you are loading a MADRIX 5 Setup, please check if the number of ACN devices in

your setup corresponds with the number that is activated. The Setup stores the number

of devices. But if you changed the amount and then loaded the Setup, the newly defined

number will be activated.

5] Configure Your Device

§ Make sure that your device is still selected under Preferences > Device Manager... > DMX

Devices

§ Click 

§ A new window will open.



[Part 3] Using MADRIX 5 Software

//74www.madrix.com

MADRIX STELLA User Manual

Set up the following settings for your devices:

§ Source Name - Allows you to set up a specific name for the device. This name is send via

network as well. Therefore, interfaces may be able to retrieve this name and can be configured

to receive data from this source.

- If you are using the default name MADRIX U:X, the universe will automatically be displayed in

the name [represented by X: 1, 2, 3, etc.].

§ ACN Universe - Defines the DMX universe from which data is received. 

- Set up the same universe that is set up in your MADRIX STELLA according to the Web

Configuration. By default, MADRIX STELLA sends input data to network universe 256 for

DMX 1 and universe 255 for DMX 2. You can change these settings in the Web

Configuration if required.

- According to the Streaming ACN specifications, MADRIX 5 will automatically change the ACN IP

Address according to the ACN Universe.

§ Click Apply to confirm your changes.

§ Click OK to close the window.

6] Enable DMX-IN

§ Go to the menu Preferences > Device Manager... > DMX Input
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§ Select your preferred DMX Universe in the list.

[By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN

universes, you can change the setting under menu Preferences > Options... > Performance]

§ Choose your DMX-IN Device in the section Device

§ [If needed, you can disable DMX-IN by choosing None for your DMX-IN Device in the section

Device]
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§ sACN input is now activated. MADRIX 5 can already receive DMX data.

§ Now, choose how to use incoming data as explained below.

 

7] sACN Input

Data

§ At this point, MADRIX 5 is now already receiving any incoming data.

§ You can now use this data, for example for Scripts and Macros.

§ If you want to monitor incoming signals, select your DMX universe/DMX device in the list and

click 

Mapping

§ Use Mapping, if you want to route incoming DMX signals through MADRIX 5 to your output [DMX-

Thru].

§ First, select your device in the list.

§ Activate Mapping

§ This feature maps incoming data to the specified DMX universe and channels.
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§ Configure the following settings in the section Mapping

- Map Channels From - Defines which incoming channels are used. This is the start channel to

specify the range of channels.

- To - Defines which incoming channels are used. This is the end channel to specify the range of

channels.

- To Universe - Defines onto which output DMX universe MADRIX 5 should map the specified

range of incoming channels.

- Start At Channel - Defines the first DMX channel of the output DMX universe MADRIX 5 should

use.

- Use HTP - Activates the Highest Takes Precedence feature. You can map incoming data to a

DMX address range that MADRIX 5 already controls. Use HTP and MADRIX 5 will compare

incoming values with the DMX data it sends to the DMX output. As a result, MADRIX 5 will only

use the highest of both values on a particular channel and send it to the output.

§ Click Apply to confirm.

Remote Control

§ Use Remote Control, if you want to control the MADRIX 5 Software remotely

§ First, select your device in the list.
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§ Activate Remote

§ Select one of the built-in protocols in the section Remote Control as explained below

or create your own remote configuration.

Open - Loads a previously saved MADRIX 5

DMX Remote Configuration file [of the file type

*.mdrx].

Protocols - Choose from a pre-configured

protocol [configuration].

DMX-IN Remote Editor - Allows you to modify

a configuration or create a new configuration. 

Start Address - Defines on which particular

DMX channel the protocol should start. The
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whole protocol will be mapped to this new

address area.

DMX Watcher - Opens the DMX Watcher to

monitor your DMX output or input.

Trigger

§ Use Trigger, if you want to use incoming signals for the MADRIX 5 TRI Effects.

§ First, select your device in the list.

§ Activate Trigger
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Port - Defines the port [Port 1 - 8] that is

assigned to this DMX-IN Device. MADRIX 5 allows

you to send trigger signals from up to 8 different

devices [8 ports] and assign a MADRIX 5 TRI

Effect the corresponding port.

Value Range - Defines the range of incoming

DMX values that can be used as trigger signal.

- The minimum and default value is 1. 

- The maximum and default value is 512.

Assign Minimum Value - Automatically assigns

the minimum value when using the controller.

- Click Assign and use the control on your

controller for the minimum value and the value

will be set automatically in the MADRIX 5

Software.

Assign Maximum Value - Automatically assigns

the maximum value when using the controller.

- Click Assign and use the control on your

controller for the maximum value and the value

will be set automatically in the MADRIX 5

Software.

3.6 Input [USB]

This topic includes:

§ DMX-IN Via USB

§ 1] Initial Configuration

§ 2] Enabling Drivers In MADRIX 5
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§ 3] Activating Devices

§ 4] Activating DMX Input

§ 5] DMX-IN

DMX-IN Via USB

You can connect the STELLA directly via USB to the computer that runs the MADRIX 5 Software.

Data is sent to the STELLA via a port and from the STELLA to MADRIX 5 via USB.

1] Initial Configuration

§ Connect your external DMX controller to the required DMX port of MADRIX STELLA.

§ Connect MADRIX STELLA to your computer via USB.

[Use the provided USB cable]

§ Make sure to check the power-management options of Windows. Learn more »PC Power

Management

2] Enabling Drivers In MADRIX 5

§ Go to the menu Preferences > Options... > Devices USB 

[Keyboard shortcut: Ctrl+Alt+O > Devices USB]

§ Activate MADRIX STELLA

[The option is activated by default.]

§ Click Apply

§ Close the window with OK
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3] Activating Devices

§ Go to the menu Preferences > Device Manager... > DMX Devices 

[Keyboard shortcut: F4]

§ Your STELLA devices and their two ports will appear in the list.

§ If your devices are not in the list, click 

[In the screenshot below, one STELLA is connected.]



[Part 3] Using MADRIX 5 Software

//83www.madrix.com

MADRIX STELLA User Manual

§ Select the required port in the list.

§ Right Mouse Click on the column OUT / IN to set to IN for data input.

§ If required, change the frame time.

- Right Mouse Click or Left Mouse Double-Click on the column ms / FPS and enter the

required number.

- The frame time [in milliseconds; ms] affects the frame rate. The frame rate specifies how fast

data is sent to the device or received from it [in Frames Per Second; FPS].
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- Increase the frame time in order to decrease the frame rate [e.g., 40 ms = 25 FPS].

- Decrease the frame time in order to increase the frame rate [e.g., 20 ms = 50 FPS].

- The default value is 30 ms / 33.3 FPS.

- The minimum value is 1000 ms / 1 FPS. 

- The maximum value is 5 ms / 200 FPS. 

   Please note: If you want to output high frame rates, make sure to set Main Mixing FPS in the

Options to the same value in order to render the same frame rate [It is set to 50 FPS by default.

Otherwise, frames will be duplicated].

   Please note: If you want to input high frame rates, make sure to set DMX Controller Input FPS

in the Options to the same value in order to process the same frame rate [It is set to 50 FPS by

default. Otherwise, frames will be duplicated].

- Some LED fixtures might have problems with a low frame time / high frame rate. Then,

it is recommended to increase the frame time / decrease the frame rate.

4] Activating DMX Input

§ Go to the menu Preferences > Device Manager... > DMX Input
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§ Select your preferred DMX Universe in the list.

[By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN

universes, you can change the setting under menu Preferences > Options... > Performance]

§ Choose your DMX-IN Device in the section Device. Select MADRIX STELLA

§ DMX-IN is now activated. MADRIX 5 can already receive DMX data.

§ Now, choose how to use incoming data as explained below.

5] DMX-IN

Data

§ At this point, MADRIX 5 is now already receiving any incoming data.

§ You can now use this data, for example for Scripts and Macros.

§ If you want to monitor incoming signals, select your DMX universe/DMX device in the list and

click 
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Mapping

§ Use Mapping, if you want to route incoming DMX signals through MADRIX 5 to your output [DMX-

Thru].

§ First, select your device in the list.

§ Activate Mapping

§ This feature maps incoming data to the specified DMX universe and channels.

§ Configure the following settings in the section Mapping

- Map Channels From - Defines which incoming channels are used. This is the start channel to

specify the range of channels.

- To - Defines which incoming channels are used. This is the end channel to specify the range of

channels.

- To Universe - Defines onto which output DMX universe MADRIX 5 should map the specified

range of incoming channels.

- Start At Channel - Defines the first DMX channel of the output DMX universe MADRIX 5 should

use.

- Use HTP - Activates the Highest Takes Precedence feature. You can map incoming data to a

DMX address range that MADRIX 5 already controls. Use HTP and MADRIX 5 will compare
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incoming values with the DMX data it sends to the DMX output. As a result, MADRIX 5 will only

use the highest of both values on a particular channel and send it to the output.

§ Click Apply to confirm.

Remote Control

§ Use Remote Control, if you want to control the MADRIX 5 Software remotely

§ First, select your device in the list.

§ Activate Remote

§ Select one of the built-in protocols in the section Remote Control as explained below

or create your own remote configuration.

Open - Loads a previously saved MADRIX 5

DMX Remote Configuration file [of the file type

*.mdrx].
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Protocols - Choose from a pre-configured

protocol [configuration].

DMX-IN Remote Editor - Allows you to modify

a configuration or create a new configuration. 

Start Address - Defines on which particular

DMX channel the protocol should start. The

whole protocol will be mapped to this new

address area.

DMX Watcher - Opens the DMX Watcher to

monitor your DMX output or input.

Trigger

§ Use Trigger, if you want to use incoming signals for the MADRIX 5 TRI Effects.

§ First, select your device in the list.

§ Activate Trigger
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Port - Defines the port [Port 1 - 8] that is

assigned to this DMX-IN Device. MADRIX 5 allows

you to send trigger signals from up to 8 different

devices [8 ports] and assign a MADRIX 5 TRI

Effect the corresponding port.

Value Range - Defines the range of incoming

DMX values that can be used as trigger signal.

- The minimum and default value is 1. 

- The maximum and default value is 512.

Assign Minimum Value - Automatically assigns

the minimum value when using the controller.

- Click Assign and use the control on your

controller for the minimum value and the value
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will be set automatically in the MADRIX 5

Software.

Assign Maximum Value - Automatically assigns

the maximum value when using the controller.

- Click Assign and use the control on your

controller for the maximum value and the value

will be set automatically in the MADRIX 5

Software.
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4 Technical Support

Topics Of This Chapter

§ Firmware Updates

4.1 Firmware Updates

This topic includes:

§ Overview

§ MADRIX HARDWARE MANAGER

§ Available Firmware Updates

Overview

It is highly recommended to update the firmware should a new firmware version become available. 

MADRIX HARDWARE MANAGER

To update your devices, please use the separate MADRIX HARDWARE MANAGER software.

Learn more »MADRIX HARDWARE MANAGER [USB / Ethernet] 

Available Firmware Updates

Sorted in descending order.

Latest Version Highlights
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STELLA Firmware
6.04.0889

Release Date
May 2024

§ Art-Net 4: Added Squawking to the PollReply for better device
identification in [software or hardware] controllers who support this
feature (#10691).

STELLA Firmware
6.03.0862

Release Date
December 2023

§ Web Configuration: Improved the NetBIOS functionality by writing out
the full address for web browsers (#10355).

§ Improved discarding of ArtRdm draft packets by additionally checking
the ArtRdm version flag (#10363).

§ Fixed an issue with the 'Node Report' field of the Art-Net implementation
(#10370).

STELLA Firmware
6.02.7429

§ Web Configuration: Added NetBIOS functionality and information in the
Device Information section to find and connect to devices using the
NetBIOS name instead of the IP address (#10246).

STELLA Firmware
6.01.7426

Release Date
September 2023

§ Web Configuration: Now shows the RDM UID Count for discovered and
connected RDM devices (#9806, #9947).

§ Web Configuration: Checkmarks for checkboxes are now shown in the
correct green accent color (#9963).

§ Fixed an issue that did ignore the BindIndex via ArtAdress; resulting in
users only being able to set the first universe via ArtAddress (#10134).

STELLA Firmware
4.07.7413

Release Date
April 2023

§ Fixed an issue that did not correctly join and leave universe assignments
in case of sACN (#9575).

STELLA Firmware
4.06.7408

Release Date
April 2023

§ Fixed an issue that uncontrolledly added zeros or possibly data to the
HTML source code of the web configuration via a Firmware's hash value
(#9569).

STELLA Firmware
4.05.7407

Release Date
January 2023

§ Improved reliability by ensuring that network settings are always
properly saved (#9213).

§ Added the development cd hash to the firmware version to the Device
Information section (#9361).

STELLA Firmware
4.03.7401

MADRIX Version
MADRIX 5.5c

Release Date
October 2022

-

STELLA Firmware
4.02.7398

§ The bootloader version can now be provided by the firmware over USB
(#8874).
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MADRIX Version
MADRIX 5.5b

Release Date
August 2022

STELLA Firmware
4.01.7397

Bootloader
4.01.9396

MADRIX Version
MADRIX 5.5a

Release Date
July 2022

§ Added support for new hardware components (#8029).

§ Bootloader 4.0: Fixed an issue that did not always respond to firmware
packets being sent over Art-Net (#8027).

§ Bootloader 4.0: Added support for new hardware components (#8028).

§ Bootloader 4.0: A single Art-Net PollReply is being sent after starting
and remaining in the bootloader (#8032).

§ Fixed an issue that did not disable Send Full Frames when deactivating it
for both ports (#8606).

STELLA Firmware
3.03.7390

MADRIX Version
MADRIX 5.4h

Release Date
April 2022

§ Web Configuration: Added the possibility to edit the ShortName identifier
for Art-Net (#8159).

§ Web Configuration: Added option 'Send White Frames Continually' for the
'In Case Of Missing Network Data' setting (#8169).

§ Web Configuration: Now shows the uptime of the device (#8183).

§ Increased operational robustness of the device by discarding RDM
responses that are only received from RDM Responders after the valid
response time (#8183).

STELLA Firmware
3.02.7387

MADRIX Version
MADRIX 5.4g

Release Date
March 2022

-

STELLA Firmware
3.01.7385

MADRIX Version
MADRIX 5.4f

Release Date
January 2022

§ The bootloader can now read the hardware revision/model over USB
(#7802).

§ Supports the RDM flag per universe/port according to the latest Art-Net
4 protocol revision 1.4dd2 (#7904).

§ Fixed a critical issue that could cause the bootloader on hardware
revision 1.2 to freeze at startup with the status-LED Power being
permanently on (#7808).

STELLA Firmware
3.00.7380

MADRIX Version
MADRIX 5.4e

Release Date
October 2021

§ Updated the system of the device (#6971, #7114, #7504).

§ Updated the bootloader of the device (#7544).

§ A single bootloader now supports both Ethernet ports (#7695).

§ A maximum of 170 RDM Responders can now be discovered per port
(#7479).

§ Improved the timing of RDM packets (#7479).
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§ RDM packets are now also forwarded during a discovery of connected
RDM Responders (#6726).

§ All RDM packets that are not processed by the device itself are
forwarded unchanged to the RDM Controller (#7639).

§ Changes regarding connected RDM Responders are now also evaluated
with the help of the UID itself in addition to the UID count (#7683).

§ Fixed an issue that stilled showed the previous IP address when setting
a new IP address via ArtIpProg over Art-Net (#7347).

§ Fixed an issue that did not consistently initiate a PollReply when
changing settings using the web configuration page (#7689).

STELLA Firmware
2.06.7355

MADRIX Version
MADRIX 5.4c

Release Date
July 2021

§ Web configuration page: Added the option to set the Output Intensity
(#7317).

§ Web configuration page: Added the option to set the Upper Intensity
Limit (#7317).

§ Web configuration page: Added the option to reboot the device
(#7403).

§ Web configuration page: Added the option to reset the device to
factory default settings (#7403).

§ Fixed an issue that could prevent changed settings from being saved in
rare cases after a power cycle (#5382).

§ Fixed an issue that did not show the favicon in web browsers (#6460).

§ Fixed that the option Send The Last Received Frame Continually did not
work correctly when a universe failed after having received two
universes of data (#7344).

STELLA Firmware
2.05.7308

MADRIX Version
MADRIX 5.4b

Release Date
May 2021

§ The device now replies with ArtTodData to an ArtTodControl request for
improved compatibility with Art-Net 4 (#6958).

§ Improved and streamlined how the device replies to ArtTodData with
Unicast, Directed Broadcast, or Limited Broadcast (#6959).

STELLA Firmware
2.04.7304

MADRIX Version
MADRIX 5.4a

Release Date
February 2021

§ Web configuration page: Fixed an incorrect IP address shown for sACN
Multicast Mode (#6562).

§ Fixed a critical issue that could halt the device when receiving an Art-
Net OpIpProg request (#6852).

§ Fixed an issue that did not save the chosen value for the 'In Case Of
Network Data Timeout' setting for the second port (#6899).

§ Fixed an issue that did send back the On/Off state of RDM for Port 2
incorrectly in the Art-Net PollReply (#6915).

STELLA Firmware
2.03.7291

MADRIX Version
MADRIX 5.4

§ Fixed minor issues.
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Release Date
December 2020

STELLA Firmware
2.03.7261

MADRIX Version
MADRIX 5.3

Release Date
May 2020

-

STELLA Firmware
2.03.7259

MADRIX Version
MADRIX 5.2

Release Date
November 2019

§ Channel Order 4-1-2-3 has been added.

§ Now clears the input buffer in order to discard obsolete and incorrect
RDM packages before sending out new requests to avoid that packages
cannot be assigned and processed correctly due to timeouts.

STELLA Firmware
2.03.7252

MADRIX Version
MADRIX 5.1a

Release Date
August 2019

§ Fixed an issue that could make the device become unresponsive when
using RDM and both ports at the same time.

STELLA Firmware
2.03.7236

MADRIX Version
MADRIX 5.1

Release Date
June 2019

§ Fixed an issue that only applied a new IP address that was set over USB
after a power cycle. 

§ Fixed an issue that did continue to send the last frame that was
received over USB under certain circumstances although new network
data was received.

§ Fixed an issue that did not allow receiving data over USB when merging
data from Art-Net and sACN.

§ Fixed an issue that allowed special characters and control characters
[ASCII] in names and descriptions, which are not filtered out.

STELLA Firmware
2.02.7206

MADRIX Version
MADRIX 5.0e

Release Date
February 2019

§ Added RDM support.

§ Added support for 2 Ethernet ports [Model V1.2 required].

§ Added daisy-chain support [Model V1.2 required].

§ Web configuration page: Universes up to number 32,768 can now be
assigned.

§ During normal operation, pressing the Reset button now sends an Art-
Net PollReply [e.g., Device Manager] and a MADRIX PollReply [MADRIX
Device Configuration].

§ Changed the Art-Net PollReply to assign a separate BindIdx to each
universe.

§ Fixed an issue that did only apply a new IP address after changing it
over USB after disconnecting it from power first.



[Part 4] Technical Support

//97www.madrix.com

MADRIX STELLA User Manual

STELLA Firmware
2.01.7147

MADRIX Version
MADRIX 5.0d

Release Date
August 2018

§ Fixed an issue that did only sent out Art-Net data when setting Port 2 
to input.

§ Fixed a critical issue that could halt the device in rare cases.

STELLA Firmware
2.00.7140

MADRIX Version
MADRIX 5.0b

Release Date
July 2018

§ Web configuration page: Updated the visual appearance for MADRIX 5.

§ Web configuration page: Network universes are now also shown in
hexadecimal notation in addition to the decimal notation.

§ Added support for Streaming ACN [sACN] for input and output.

§ You can now choose the network data source: Art-Net, Streaming ACN,
or Art-Net And sACN.

§ You can set the Start Channel for each port.

§ You can change the Channel Order for the output. 

§ Added support for ArtSync.

STELLA Firmware
1.04.7082

MADRIX Version
MADRIX 3.6h

Release Date
February 2018

§ Added 4 distinct options for sending data output in case of data
connection loss [only available in the web configuration tool]:
- Send The Last Received Frame Continually
- Send Black Frames Continually
- Stop Sending After Sending A Black Frame
- Stop Sending

§ Increased the minimum output frequency that is sent on each port from
10 FPS to 20 FPS [in order to ensure functionality with lighting fixtures
that are not working correctly when receiving low frame rates].

§ Fixed an issue that could prevent reception of DMX input when Sync
Mode had been enabled in the MADRIX 3 Software.

STELLA Firmware
1.02.7035

MADRIX Version
MADRIX 3.6f

Release Date
May 2017

§ Fixed an issue that could leave the status LEDs permanently on when
using the ArtAddress functionality for Art-Net to switch from normal
operation to off while the status LEDs were currently active.

STELLA Firmware
1.02.6346

MADRIX Version
MADRIX 3.6d

Release Date
December 2016

§ Sensor data: Devices can now report back if voltage is
connected/disconnected over USB [Voltage USB].

§ Sensor data: Devices can now report back which voltage is used for
Power [Voltage Power].

§ Sensor data: For STELLA models V1.1 and higher, devices can now
report back the ambient temperature [Temperature].

§ Fixed an issue that could make the device become unresponsive under
certain circumstances when connecting, disconnecting, and calling up
the website several times in a row.

STELLA Firmware
1.01.6168

§ Web configuration page: Added Voltage to the Device Information
section.



[Part 4] Technical Support

//98www.madrix.com

MADRIX STELLA User Manual

MADRIX Version
MADRIX 3.6a

Release Date
July 2016

§ Web configuration page: Added the Refresh button to always show the
latest information that was last saved on the device in the web browser
[instead of using a browser refresh which may change settings again].

STELLA Firmware
1.01.6147

MADRIX Version
MADRIX 3.6

Release Date
May 2016

-

STELLA Firmware
1.00.6127

MADRIX Version
MADRIX 3.6 RC

Release Date
May 2016

§ Initial firmware release.
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5 General

Topics Of This Chapter

§ Glossary

§ PC Power Management

§ Tips [Microsoft Windows / Networks / USB]

§ Web Links

5.1 Glossary

2D

MADRIX 5 makes it possible to control numerous LED fixtures, also of different kinds, and to position

them according to your needs in nearly any form or shape. This could be LED walls, arch shapes,

ceilings, stripes, tiles, dance floors, etc. You can control pixel by pixel [pixel mapping].

3D

MADRIX 5 supports volumetric pixel rendering as well [voxel mapping]. That means, MADRIX 5 also

allows you to control real 3D LED matrices. This approach is fundamentally different to the 3D

projections or the physical layout of 2D surface areas that are widely known nowadays.

Art-Net

Art-Net is a communication protocol that allows to distribute DMX512 data over Ethernet network.

Often, so-called Art-Net nodes then act as Ethernet-to-DMX512 converters and hardware interfaces.

MADRIX LUNA is such an Art-Net node, for example.

Art-Net Remote

Art-Net Remote refers to DMX512 input that is sent and received over Ethernet network.

CITP

Is another communication protocol for exchanging information, often used between media servers,

lighting consoles, and visualizers.
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Colorlight 5A, Colorlight A8, Colorlight T9, Colour Smart Link

Are network-based communication protocols to control compatible LED fixtures and classified as DVI-

based output in MADRIX 5.

DMX512 [DMX-OUT]

DMX512, often abridged to DMX, is an unidirectional communication protocol used mainly to control

stage lighting, which uses 5-pin XLR connectors as defined by the standard. 3-pin connectors are

also common, but not defined as standard connectors.

When working with DMX-based products, each fixture needs a specific attribution via its DMX channel

and its DMX universe. With the specific DMX channel and DMX universe, the LED product can be

identified directly for a correct communication with the fixture.

DMX-IN

You can send or receive DMX512 data. DMX-IN refers to DMX512 input, which you can receive in

MADRIX 5.

DMX Channel

A total of 512 DMX channels is available per DMX universe. Each DMX channel is an individual control

channel. Valid values range from 0 to 255, with a total of 256 values.

DMX Universe

A DMX universe contains 512 DMX channels and represents 1 DMX line. To control more than 512

DMX channels, more than 1 DMX universes need to be used. For example, 2 DMX universes represent

1024 DMX channels.

For example, you can control 170 RGB fixtures per DMX universe. That means, calculating 170

fixtures x 3 channels results in 510 DMX channels. Therefore, channel 511 and 512 will be left empty.

And if your are using more then 170 fixtures, those DMX channels will be assigned to a new DMX

universe [e.g., DMX universe 2].
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DVI

DVI is another way to output a video signal for your LEDs. Certain LED products use this type of

communication. MADRIX 5 features 2 DVI outputs, which are 1-to-1 output windows. You can then

send the DVI outputs to any graphics card port [such as, VGA, HDMI, DVI, etc.]. Other solutions use

screen-capturing to capture such a DVI output window and send them to the LED controller via

Ethernet.

Eurolite T9

Is a network-based communication protocol to control compatible LED fixtures and classified as DVI-

based output in MADRIX 5.

Fixture

When talking about an LED product, the specific product is often called fixture. When talking about

fixtures, often you will automatically get the information about the number of color channels [e.g.,

RGB] and the number of pixels.

Input

MADRIX 5 can send data out, but at the same time data can be sent to the software. That means

data is sent to the MADRIX PC through various means [mostly USB or network]. MADRIX 5 can then

be controlled remotely by you, or you can merge or use incoming signals, etc.

IP Address

Is an identifier for devices that enables network communication. When using network protocols, it

needs to be set up for each individual sender or recipient in the network.

KiNET

KiNET, the Philips Color Kinetics network protocol, is another communication protocol. It transfers

data over Ethernet network as well. Only declared Philips Color Kinetics products work with this type

of protocol.
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MAC Address

Is a unique, technical identifier for interfaces in a network.

MA-Net

Is a proprietary communication protocol from MA Lighting between compatible products in a network.

MIDI

MIDI is short for Musical Instrument Digital Interface, a well-known technical standard that provides

standardized ways for equipment to communicate. In case of MADRIX 5, MIDI can be used for MIDI

Time Code, MIDI notes, or other MIDI hardware, such as DJ/VJ controllers.

NDI

Network Device Interface is a network-based video technology by NewTek.

Output

To control your LEDs, MADRIX 5 needs to send data to the LEDs. In this way it communicates with

your controllers and/or your LEDs. This is referred to as output. There are different ways on how this

process can work [e.g., protocols]. But most importantly, you need to configure which output method

MADRIX 5 should use in order to control your LED products.

Philips Hue

Is a proprietary range of products including communication protocol for personal wireless lighting

made by Philips Lighting.

Pixel

A pixel refers to one lighting point. When using RGB LEDs, one pixel usually includes 1 [or 2] red LEDs,

1 blue LED, and 1 green LED. 1 control channel is required for each color [3 in total per pixel], but as

a total they represent one pixel. LED fixtures often have a certain number of pixels per unit.
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Pixel Mapping

MADRIX 5 contains an effect generator as well as a graphics render engine that support pixel

rendering for 2D effects and volume rendering for 3D effects.

Remote HTTP

Remote HTTP is a way to control MADRIX 5 remotely using standards known from the internet [HTTP

- Hypertext Transfer Protocol].

RGB

The acronym stands for Red, Green, Blue. The 3 colors are the main colors for additive color mixing of

LED fixtures. As a result, a vast number of colors can be mixed.

RGBW

The acronym stands for Red, Green, Blue, White. The 4 colors are also used for additive color mixing

of LED fixtures. As a result, a vast number of colors can be mixed.

Spout

Spout is a real-time video sharing framework for Windows.

Streaming ACN [sACN / E1.31]

Streaming ACN or sACN or E1.31 is another communication protocol that allows DMX512 data to be

transmitted over Ethernet. Data is broadcasted by MADRIX 5 to recipients in the network.

Subnet Mask

Is a technical grouping mechanism for network devices. When using network protocols, it needs to be

set up for each sender or recipient in the network for correct data routing.

Virtual LED Matrix

MADRIX 5 needs to know how your LED installation looks like and which fixtures you want to use.

[You can use the Matrix Generator or the Patch for this task.] In the end you will have configured the
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virtual LED matrix with its total pixel count in X, Y, and Z set up as the Matrix Size as well as the

position and location of each pixel or fixture. The virtual LED matrix represents your LED installation in

MADRIX 5.

Volume Rendering / Voxel Mapping

MADRIX 5 contains an effect generator as well as a graphics render engine that support pixel

rendering for 2D effects and volume rendering for 3D effects.

Voxel

Voxel is short for volumetric pixel. In addition to its pixel mapping features [2D], MADRIX 5 can control

3D LED matrices, which is called voxel mapping. Lighting effects are correctly mapped to each voxel

of a 3D LED matrix.

XLR Pin Layout

XLR connectors are used for DMX512. There are different types.

5-Pin, Female 5-Pin Male Pin Assignment 3-Pin, Female 3-Pin, Male

1 Ground

2 Data -

3 Data +

4 Spare 

5 Spare

5.2 PC Power Management

This topic includes:

§ Why Is Power Management Important?

§ Usage

§ Activate High Performance

§ How To Change USB Power Settings
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Why Is Power Management Important?

We strongly recommend to deactivate all power saving options in Microsoft Windows in

order to ensure an interruption-free operation of MADRIX 5.

Microsoft Windows operating systems offer a wide variety of power-management options. In most

cases, laptops, notebooks, and netbooks benefit from a longer battery life if a good power

management is in use. But certain problems might occur because of computer power savings

nevertheless:

§ After a while your MADRIX KEY cannot be identified by the software anymore.

§ Your hardware interfaces are suddenly deactivated.

Usage

Make sure to set up power-saving settings especially if you are using:

§ A MADRIX KEY [USB dongle]

§ MIDI controllers [via USB]

§ USB hardware interfaces [such as MADRIX NEO]

§ A notebook/laptop to run MADRIX 5

Additionally:

§ Make sure to change the USB power settings.

§ Especially for notebooks, we recommend to activate the High performance power plan. 
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Activate High Performance 

This setting will make sure that your notebook or laptop will have all its potential performance

available for MADRIX 5.

§ In Windows 10, select Start > Windows System > Control Panel > Power Options, and

change the power plan to High performance

[You might need to click on Show additional plans].

How To Change USB Power Settings

§ In Windows 10, select Start > Windows System > Control Panel > Power Options > Change

plan settings
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§ Click Change advanced power settings
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§ Especially the USB settings are important. Disable the suspend settings! 

§ Change any other settings that might interrupt the operation as required.

5.3 Tips [Microsoft Windows / Networks / USB]

This topic includes:

§ Error When Saving Files

§ USB

§ The Windows Firewall

§ Working With Ethernet Networks

§ Changing The Priority Of Network Adapters

§ Working With Files

§ Operating System Security

§ Up-To-Date Drivers

§ Windows Restart / Shut Down

§ Monitoring Computer Performance



[Part 5] General

//110www.madrix.com

MADRIX STELLA User Manual

Error When Saving Files

If you are experiencing issues when trying to save files, there are two solutions to this problem:

§ Right Click > Run as administrator

- In order to save files as a user that is logged-in into Windows, you need to have the

permissions set by Windows to do so. 

- When you do not have the right permissions, saving files can lead to errors.

- To circumvent such issues, you can run the MADRIX Software as administrative computer user,

the so-called administrator.

- Perform a right mouse click on the MADRIX.exe [or a shortcut to the MADRIX 5 Software]

and choose Run as administrator

- Note: You need to have access to the administrator account (i.e., password). Logging in as

administrator grants extensive rights for any computer changes. If you are not familiar with

Windows or computers, please seek advice.

§ Choose A Different Directory

- When you are experiencing issues and running as administrator is not an option, choose a

different directory on your harddisk to save the files.

- There are locations on your computer/harddisk where you will have the permission to save

files. Choose such a location.

- Examples are:

C:\Users\USERNAME\Desktop

C:\Users\USERNAME\Documents

[USERNAME specifies your Windows account name.]
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USB

Among others, USB is an important way to work with MADRIX 5, MADRIX KEYs, MADRIX hardware

interfaces, MIDI controllers, etc. In order to ensure a stable work environment, we highly recommend

setting up corresponding USB settings in Windows. 

Learn more »PC Power Management

The Windows Firewall

Correct Settings

The primary purpose for the Windows Firewall [or any other firewall] is to block any unwanted

incoming or outgoing data and access. But this can lead to problems, when data that should go

through is automatically blocked.

MADRIX 5 will automatically set the correct firewall settings for you during the installation process. 

Please follow the steps below if this Windows message appears when you start the MADRIX 5

Software for the first time. 
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Select and set a checkmark for

§ Private networks

and

§ Public networks

§ Click Allow access to confirm.

Not selecting both options can cause problems with network communication.

Resetting The Settings

If you have already chosen the wrong options MADRIX 5, you can delete the settings and choose

again.

§ In Windows 10, go to Start > Windows System > Control Panel > Windows Defender

Firewall > Advanced settings > Inbound Rules
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§ Select and delete any entries relating to MADRIX 5 [e.g., madrix.exe, MADRIX - music makes the

light, MADRIX - LIGHTING CONTROL].

§ With your next start of MADRIX 5, select both options as described above.
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Working With Ethernet Networks

Configuration Of Network Settings

When working with network-based products and MADRIX 5 [for example, Art-Net, KiNET, sACN, etc.],

you will have to set up the IP address of your network card in Windows. Learn how to set it up here.

§ In Windows 10, go to Start > Windows System > Control Panel > Network and Sharing

Center > Change adapter settings > Local Area Connection > Properties > Internet

Protocol Version 4 (TCP/IPv4) > Properties
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Set up the following settings:

§ Enable Use the following IP address:

§ IP address - Sets the IP address for this computer and this network card. 

- If you have several network cars in your computer, you can set up an individual address for

each network card. 

- An IP address has 4 parts. Enter the complete address as explained in the specific chapter of

this user guide [e.g., 10.0.0.1]. 

- You only have to enter the numbers.

§ Subnet mask - Sets up the Subnet mask for this computer. 

- This is an important part of the network settings, just as the IP address. 

- A Subnet mask has 4 parts. Enter the complete address as explained in the specific chapter of

this user guide [e.g., 255.0.0.0]. 

- You only have to enter the numbers.

§ OK - Click to save your settings. 

- [Make also sure to close the Local Area Connection Settings with OK and close the Local

Area Connection Status window with Close.]

§ Restart the MADRIX 5 Software if you have changed any network settings!

Learn more below.
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Using Several Devices In A Network

Usually, you will use at least 2 devices in a network [for example, 1 MADRIX PC and 1 Art-Net node or

1 MADRIX PC and 1 console]. As explained above, you will need to configure various network settings

not only for your MADRIX PC but also for the other devices. 

To be able to communicate with each other, all devices have to be in "the same network". That

means:

§ All devices need to be physically connected with each other [through network equipment, such

as hubs or switch and/or network cables]

§ All devices need to have compatible network settings

Using several devices in a network does not mean that all should have the same IP address. That will

not work! 

Instead, follow these rules:

§ Set up all devices within the same IP address range, but never with the same IP address 

[for example, MADRIX PC: 10.204.226.101 and Art-Net node: 10.204.226.102]

§ Set up all devices with the same Subnet mask e.g., 255.0.0.0]

§ If recommended, set up all devices with the same Default gateway [e.g., 10.0.0.1]

Changing The Priority Of Network Adapters

You can change the order in which Windows and MADRIX 5 accesses your network adapters. By

changing the order, you can specify which network adapter [network card] is used first and as the

main connection. 

§ 1] In Windows 10, go to Start > Windows System > Control Panel > Network and Sharing

Center > Change adapter settings 
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§ 2] Press Alt on your keyboard.

- A menu appears at the top, which is otherwise hidden.

§ 3] Go to Advanced > Advanced Settings...

- A new window opens.
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§ 4] Select your preferred network connection[s] in the list of Connections:

§ 5] Change the order by clicking on the green up and down arrow buttons on the right hand

side.

- The connection which is listed on top, is the first and prioritized adapter.

§ 6] Click OK to confirm.

§ 7] Restart your computer.

Working With Files

When working with computers in general, you should be aware that any digital data is sensitive and

prone to failure and hardware errors. 

We recommend

§ to save regularly when creating a show in MADRIX 5.

§ to make backup copies of your show files from time to time [MADRIX 5 Setup files]

§ to make backup copies to different or external storage mediums [e.g., USB stick/thumbdrive].
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Operating System Security

It is recommended

§ to keep Windows up-to-date by installing security updates using Windows Update

§ to use a virus detection software when working with files from external sources.

Up-To-Date Drivers

Please always keep all component drivers up to date by installing the latest available driver. Among

others, this may include drivers for:

§ Processor

§ Graphics Card

§ USB

§ Capture Card

§ Sound/Audio Card

§ Video Codecs

Windows Restart / Shut Down

According to the requirements of Windows, MADRIX 5 will behave in the following way:

§ MADRIX 5 will be closed instantly, when you trigger a Restart or Shut Down of Windows.

§ If you have not saved any changes yet, you may be provided the chance and a short time frame

[30 seconds] to react and save your progress before the MADRIX 5 Software is forcefully closed

by Windows itself.
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§ Make sure to save your files before executing a Restart or Shut Down!

Monitoring Computer Performance

Windows allows you to monitor the overall performance of your computer. 

§ Press Ctrl + Alt + Del and choose Start Task Manager

[German shortcut: Strg + Alt + Entf]

§ A new window opens [Task Manager].

§ Go to Performance

§ You can now monitor the CPU Usage as well as the Memory usage. 

§ MADRIX 5 has its own monitoring tools.
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5.4 Web Links

This topic includes:

§ Overview

Overview

You can find a selection of useful internet links here:

§ MADRIX Website

»www.madrix.com

§ Drivers

»www.madrix.com/support/download

§ User Guides [Online And Downloadable PDF]

»help.madrix.com

§ Hardware Technical Manuals / Quick Start Guides [Downloadable PDF]

»help.madrix.com

§ Online Forum

»www.madrix.com/support/forum

§ Software Release Notes

»www.madrix.com/products/software/releases

§ Online Text Tutorials

»help.madrix.com/tutorials/html/index.html

§ Video Tutorials

»https://www.madrix.com/training/video-tutorials

https://www.madrix.com/
https://www.madrix.com/support/download
http://help.madrix.com/
http://help.madrix.com/
https://www.madrix.com/support/forum
https://www.madrix.com/products/software/releases
http://help.madrix.com/tutorials/html/index.html
https://www.madrix.com/training/video-tutorials
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6 Legal

This topic includes:

§ Introduction

§ Topics Of This Chapter

Introduction

Legal includes all legal documents and information, including copyright and more.

Topics Of This Chapter

§ Imprint And Copyright

6.1 Imprint And Copyright

This topic includes:

§ Company And Address

§ Copyright

§ Credits
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Company And Address

inoage GmbH

Wiener Straße 56

01219 Dresden

Germany

Managing Directors: Christian Hertel, Sebastian Pinzer, Sebastian Wissmann

Phone: +49 351 862 6869 0

Fax: +49 351 862 6869 68

Web: »www.madrix.com

E-mail: »info@madrix.com

Copyright

© Copyright (C) 2001 – 2024 inoage GmbH. All rights reserved.

MADRIX® is a registered trademark of inoage GmbH. 

All other company names and/or product names are trademarks and/or entered trademarks of their

respective holders. The product might not always be conforming to the presentation, features, and

performances. Technical data can differ slightly, depending on the operating system and the chosen

hardware. 

We withhold the option of changes without notification. inoage GmbH does not give any guaranty for

function capability for a certain purpose, the marked ability or other features of the product. No other

guaranty claims, on legal or other terms, can be enforced. 

http://www.madrix.com
mailto:info@madrix.com
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Under no circumstances does inoage GmbH take on the responsibility for liabilities for faults for losses

in sales volume or profits, that occur through the usage of the product, through the serviceability,

through abuse, happenings, circumstances or actions, that we have no influence on. No matter if the

damages were caused by the holder of the product or a third person.

Credits

§ Art-Net™ - Designed by and Copyright Artistic Licence Holdings Ltd.

§ Other product and company names, terms, or [trade] marks are the property of their respective

holders.
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